Drivers propriétaires ATI-RADEON (Amd) sur ArchLinux : catalyst-test

Rédigé par mumbly - - Aucun commentaire

Voici un petit tuto "pas-à-pas" pour installer les drivers proprio ATI-AMD.
Pour info, je possède une carte graphique avec un chip ATI RADEON HD6800 series...

sudo pacman-key -r 653C3094
sudo pacman-key --lsign-key 653C3094

sudo nano /etc/pacman.conf

/!\ : Catalyst actuellement, ne supporte pas xorg-server supérieure à une version 1.17. Comme, au 21/12/16, par défaut, c'est xorg-server 1.18 qui est installé sous ArchLinux, il va falloir "downgrader" xorg.
/!\ : Mettez les lignes suivantes dans votre pacman.conf EN PREMIER DANS LE FICHIER !!! car sinon ca ne sera pas pris en compte !

[xorg117]
Server = http://catalyst.wirephire.com/repo/xorg117/$arch
## Mirrors, if the primary server does not work or is too slow:
#Server = http://mirror.hactar.xyz/Vi0L0/xorg117/$arch

Pendant que vous êtes dans ce fichier, vérifiez bien que vous avez les lignes suivantes dans votre fichier (lignes décommentées...) :
[multilib]
Include = /etc/pacman.d/mirrorlist

Mettez à jour :
sudo pacman -Syyuu

Désinstallez les autres drivers :
sudo pacman -Rcc lib32-ati-dri ati-dri xf86-video-ati

On installe catalyst-test depuis AUR :
yaourt catalyst-test

On installe acpid et qt4 :
sudo pacman -S acpid qt4

On configure atieventsd pour démarrer au boot :
sudo systemctl enable atieventsd
sudo systemctl start
atieventsd
 

On configure X (Ceci est pour un seul moniteur) :
aticonfig --initial

Eventuellement, on blacklist Radeon :
Si ce fichier existe :
/etc/modprobe.d/modprobe.conf
On met ça dedans :
blacklist radeon

On configure Grub
sudo nano /etc/default/grub
On ajoute :
GRUB_CMDLINE_LINUX="nomodeset"
On met à jour Grub :
grub-mkconfig -o /boot/grub/grub.cfg

Cette manip semble désormais inutile et ajoute même une erreur au boot : "Error : No ums support in radeon module"

Et... on redémarre :D
sudo reboot

 

Impression des pdf sous Arch Linux

Rédigé par mumbly - - Aucun commentaire

J'ai cru tomber dingue avec mon imprimante : tout fonctionnait SAUF l'impression des pdf.

En essayant d'imprimer un document pdf avec mon appli favorite, je cliquais sur Imprimer et ... monimprimante n'apparaissait pas dans la liste des imprimante ! Argghhhh ! :/

Après une petite recherche : Bingo ! Il faut donc installer le paquet gtk3-print-backends... et là tout fonctionne !

Lien symbolique

Rédigé par mumbly - - Aucun commentaire

Note à moi :

Comme je ne suis pas fichu de me rappeller de cette simple commande (je dois avoir un problème psy ... c'est pas possible autrement ! :D ), je rappelle ici la démarche pour créer un lien symbolique sous Linux et autres unix :

ln -s fichier-existant nouveau-fichier

Fil RSS des articles de cette catégorie